Sign in to follow this  
Followers 0
Verso

Nieuwe HD Traffic receiver geen contact met server

198 posts in this topic

Blijf toch nog effe door ouwehoeren :wink: herinner mij opeens dat toen je de 930 bij de ANWB kocht,

daar een HD T ontvanger bij zat.

Is dat de HD T ontvanger waar we het nu over hebben?, want op jouw 930 zat een navcore die er standaard

niet op kon zitten en toen heb ik nog gezegd, dat de kaboutertjes dat dan gedaan zouden hebben.

Mis ik iets ik dacht dat het om een nieuwe ontvanger van Halfords ging rechtstreeks uit gesealde doos ??????

Share this post


Link to post
Share on other sites
Mis ik iets ik dacht dat het om een nieuwe ontvanger van Halfords ging rechtstreeks uit gesealde doos ??????

Dacht ik eerst ook, maar hij had er ook nog ene van een gekochte 930 via de ANWB (een zogenaamde DEMO

in een dichtgesealde doos, met een navcore erop die er standaard nooit op kon zitten) .

Lees z'n postjes maar door (beetje bij het begin beginnen) . :wink: :unknw:

Share this post


Link to post
Share on other sites

Het is een nieuwe ontvanger uit een gesealde doos. Die moet gewoon goed zijn. Dat kan niet anders.

Die van de Anwb werkt, alleen die gebruikt mijn vrouw voor de TT 930 van haar zelf.

Die was dus nog niet gebruikt (gelukkig).

Ik heb er dus een van Halfords en die doet niks als alleen verbinden met het netwerk, maar niet met de server.

vwb die navcore brgrijp ik je niet helemaal waarom die er niet op kan staan.

Kaart is 830.2305 en nc is 8.351

Heb net gekeken maar dat is precies het zelfde als mijn eigen 730 allemaal.

Gr Fred

Edited by kombi-force-rotax

Share this post


Link to post
Share on other sites
Het is een nieuwe ontvanger uit een gesealde doos. Die moet gewoon goed zijn. Dat kan niet anders.

Die van de Anwb werkt, alleen die gebruikt mijn vrouw voor de TT 930 van haar zelf.

Die was dus nog niet gebruikt (gelukkig).

vwb die navcore brgrijp ik je niet helemaal waarom die er niet op kan staan.

Kaart is 830.2305 en nc is 8.351

Heb net gekeken maar dat is precies het zelfde als mijn eigen 730 allemaal.

Ik heb er dus een van Halfords en die doet niks als alleen verbinden met het netwerk, maar niet met de server.

Gr Fred

Duidelijk, die was dus ook goed. :unknw:

Toen je de 930 uit de doos haalde, had je kaart v800.1762 en een navcore 8.351 maar dat maakt niet meer uit.

(vergeet het maar)

Moraal van het verhaal: ligt niet aan de 730 en de 930, ligt niet aan de eerdere verlopen receiver(per 7 sep),

ligt niet aan de receiver van de 930 en het ligt ook niet aan TomTom.

Het ligt gewoon aan de nieuwe dichtgesealde receiver van Hallfords (die is niet goed) . :wink:

Share this post


Link to post
Share on other sites
Duidelijk, die was dus ook goed. :good:

Toen je de 930 uit de doos haalde, had je kaart v800.1762 en een navcore 8.351 maar dat maakt niet meer uit.

(vergeet het maar)

Moraal van het verhaal: ligt niet aan de 730 en de 930, ligt niet aan de eerdere verlopen receiver(per 7 sep),

ligt niet aan de receiver van de 930 en het ligt ook niet aan TomTom.

Het ligt gewoon aan de nieuwe dichtgesealde receiver van Hallfords (die is niet goed) . :unknw:

Volgens die knakker van TT moest hij handmatig aangemeld worden bij TT.

Ik moest alle gegevens via klembord oversturen en dan zou ik er iets van horen.

Hoop dat dat nog is in 2009. :wink:

Moet het nu ff met mijn Tmc draadje doen.

Die nieuwere kaart heb ik gratis gehad van TT. Dat is toevallig wel goed gegaan. :good:

Dat is ondertussen ook niet meer de nieuwste, maar dat maakt niet uit.

Gr Fred

Edited by kombi-force-rotax

Share this post


Link to post
Share on other sites
Toen je de 930 uit de doos haalde, had je kaart v800.1762 en een navcore 8.351 maar dat maakt niet meer uit.

(vergeet het maar)

Ik herinner me die discussie ook nog....en dacht meteen aan het feit dat toen kaart v8.00 uitkwam, er nog helemaal GEEN Navcore 8.351 bestond. :wink:

Die NC 8.351 kwam volgens mij pas uit met kaart v8.25 of zelfs 8.30

Edited by BramvT

Share this post


Link to post
Share on other sites
Volgens die knakker van TT moest hij handmatig aangemeld worden bij TT.

Ik moest alle gegevens via klembord oversturen en dan zou ik er iets van horen.

Hoop dat dat nog is in 2009. :wink:

Moet het nu ff met mijn Tmc draadje doen.

Die nieuwere kaart heb ik gratis gehad van TT. Dat is toevallig wel goed gegaan. :good:

Dat is ondertussen ook niet meer de nieuwste, maar dat maakt niet uit.

Gr Fred

Nog 1 dingetje en dan kap ik ermee :unknw: :

Sluit de goed werkende HD T ontvanger van de 930 (van jouw vrouwke) eens op de 730 aan.

(of heb je dat al geprobeerd?)

Share this post


Link to post
Share on other sites
Ik herinner me die discussie ook nog....en dacht meteen aan het feit dat toen kaart v8.00 uitkwam, er nog helemaal GEEN Navcore 8.351 bestond. :wink:

Die NC 8.351 kwam volgens mij pas uit met kaart v8.25 of zelfs 8.30

Klopt, daarom had ik het ook over de >>kaboutertjes<< :unknw:

Share this post


Link to post
Share on other sites
Nog 1 dingetje en dan kap ik ermee :wink: :

Sluit de goed werkende HD T ontvanger van de 930 (van jouw vrouwke) eens op de 730 aan.

(of heb je dat al geprobeerd?)

Dat heb ik al gedaan. Je wil niet weten welke combie's ik al geprobeert heb. Dan werkt hij dus wel. Het ligt echt aan de nieuwe ontvanger die dus schijnbaar door TT moet worden geactiveert.

Afwachten dus maar iig bedankt voor het meedenken.

Gr Fred

Share this post


Link to post
Share on other sites
Dat heb ik al gedaan. Je wil niet weten welke combie's ik al geprobeert heb. Dan werkt hij dus wel. Het ligt echt aan de nieuwe ontvanger die dus schijnbaar door TT moet worden geactiveert.

Afwachten dus maar iig bedankt voor het meedenken.

Gr Fred

Nou, dan zijn we eruit.

TT en jij zitten al een week moeilijk te doen, maar je moet als een speer naar Hallfords en die klote receiver

ruilen voor een andere (dan is het probleem opgelost, toch???) .

Share this post


Link to post
Share on other sites
Nou, dan zijn we eruit.

TT en jij zitten al een week moeilijk te doen, maar je moet als een speer naar Hallfords en die klote receiver

ruilen voor een andere (dan is het probleem opgelost, toch???) .

Ik wacht nog ff het antwoordt af van TT. Kan me haast niet voorstellen dat een nieuwe ontvanger uit een gesealde doos niet goed zou zijn. Die vorige die nu verlopen is kwam ook uit zo'n zelfde doos. Trouwens ik denk dat ik hem toch al niet terug kan brengen, omdat ik die al een week of 6 geleden heb gekocht.

Ik heb er goede hoop op dat ze hem aan de praat krijgen. :wink:

Ps dat moeilijk doen is het probleem met die nieuwe kaart waarbij Hd traffic helemaal niet werkt door die foute dat bestanden.

Ik was daar trouwens niet de enigste met dat zelfde probleem. Ik heb me er bij neergelegt en werk dus maar met de oude kaart.

Dit geval staat dus helemaal los daarvan.

Gr Fred

Edited by kombi-force-rotax

Share this post


Link to post
Share on other sites
Nou, dan zijn we eruit.

TT en jij zitten al een week moeilijk te doen, maar je moet als een speer naar Hallfords en die klote receiver

ruilen voor een andere (dan is het probleem opgelost, toch???) .

Aangezien meerderen met de receivers moeilijk zitten te doen, is wat mij betreft niet de verdenking op Halfords, als zijnde degene die niet-functionerende receivers verkoopt, maar TomTom die ergens iets niet goed heeft in de software of instellingen of ... :unknw:

Sterker nog, ik heb een receiver van TomTom ontvangen, die toen die eindelijk verbinding kon maken met de TomTom server (om een lang verhaal kort te maken), hij aangaf dat er een fout op de TomTom server heeft plaatsgevonden. :wink:

Share this post


Link to post
Share on other sites
Aangezien meerderen met de receivers moeilijk zitten te doen, is wat mij betreft niet de verdenking op Halfords, als zijnde degene die niet-functionerende receivers verkoopt, maar TomTom die ergens iets niet goed heeft in de software of instellingen of ... :unknw:

Sterker nog, ik heb een receiver van TomTom ontvangen, die toen die eindelijk verbinding kon maken met de TomTom server (om een lang verhaal kort te maken), hij aangaf dat er een fout op de TomTom server heeft plaatsgevonden. :wink:

Dat vertelde die jongen van TT ook. Hij zei dat de ontvanger handmatig "aan" gezet moest worden.

Ik wacht wel ff een paar dagen af. Krijg ik dan geen bericht bel ik maar weer eens.

Gr Fred

Share this post


Link to post
Share on other sites
Aangezien meerderen met de receivers moeilijk zitten te doen, is wat mij betreft niet de verdenking op Halfords, als zijnde degene die niet-functionerende receivers verkoopt.

Sterker nog, ik heb een receiver van TomTom ontvangen, die toen die eindelijk verbinding kon maken met de TomTom server (om een lang verhaal kort te maken), hij aangaf dat er een fout op de TomTom server heeft plaatsgevonden. :wink:

Dat heb ik ook niet gezegd, je haalt 2 dingen door elkaar. In Fred's geval is, het een ontvanger die totaal

niets doet, terwijl zijn eerdere ontvanger (waarvan het proefabo per 7 september afliep) zonder problemen

werkte. Ook de ontvanger van de 930 (van zijn vrouw) werkt zowel op de 930 als op de 730 zonder probleem.

Dan zit het toch in die receiver van Halfords (en dat die toevallig van Halfords vandaan komt, maakt niet uit,

had ook van een andere leverancier kunnen zijn) .

Dat zijn gevallen, die inderdaad handmatig op te lossen zijn.

Maarre, we zullen het afwachten en zien of de Halford's receiver alsnog handmatig, aan de praat is te krijgen.

Edited by germ

Share this post


Link to post
Share on other sites
Heb TT maar weer eens gebelt. Volgens die jongen aan de tel. is het een kwestie van handmatig aanzetten van de ontvanger. Heb alle gegevens doorgestuurt en krijg dan reactie terug als het goed is.

Ben benieuwdt of het gaat lukken.

Gr Fred

Nou je gelooft het niet. Krijg een standaard mail waarin ik ongeveer 1 uur werk heb met alles er af en weer er op te zetten.

Heb het maar gedaan. Je weet maar nooit, en jullie raden het al. HET WERKT NOG NIET.

Staat er onder aan de mail dat wanneer het niet werkt er een reparatie aan mijn TT moet gebeuren. Zijn ze nu helemaal daar. Die TT is niks mis mee. Het enigste wat ze moeten doen is de blokkade weghalen van de ontvanger.

Zelfs dat lukt ze niet.

Ze willen nu hebben dat ik het ding op stuur voor reparatie. :mega_shok:

Had een back-up gemaakt die ik er nu maar weer terug op zet, en ga ze morgen maar weer eens bellen.

Gr Fred

Share this post


Link to post
Share on other sites
Dat heb ik ook niet gezegd, je haalt 2 dingen door elkaar. In Fred's geval is, het een ontvanger die totaal

niets doet, terwijl zijn eerdere ontvanger (waarvan het proefabo per 7 september afliep) zonder problemen

werkte.

....

Maarre, we zullen het afwachten en zien of de Halford's receiver alsnog handmatig, aan de praat is te krijgen.

Ik weet niet meer of ik het gemeld heb in een van de draadjes, maar mijn vorige ontvanger heeft perfect gefunctioneerd tot ergens begin augustus (toen liep mijn proefabo af). Ik heb dus een soortgelijk geval als Fred aan de TomTom.

Maar inderdaad, we wachten nog even af. :mega_shok: Ik ben druk in onderhandeling met TomTom over een goed aanbod. Als ik e.e.a. in handen heb, dan laat ik dat weten.

Share this post


Link to post
Share on other sites
Ik weet niet meer of ik het gemeld heb in een van de draadjes, maar mijn vorige ontvanger heeft perfect gefunctioneerd tot ergens begin augustus (toen liep mijn proefabo af). Ik heb dus een soortgelijk geval als Fred aan de TomTom.

Maar inderdaad, we wachten nog even af. :mega_shok: Ik ben druk in onderhandeling met TomTom over een goed aanbod. Als ik e.e.a. in handen heb, dan laat ik dat weten.

Het lijkt wel het zelfde probleem als ik heb dus. Nieuwe ontvanger die gewoon geen contact maakt met de server.

Ik ga morgen weer bellen. Het enigste wat ik graag wil is dat ze dat ding gewoon activeren of aanzetten. ik wil alleen maar weer 6 maandjes hd traffic. Verder niks.

Als je iets weet rob laat het hier dan horen. Ik doe dat natuurlijk ook.

Gr Fred

Share this post


Link to post
Share on other sites

Na deze thread gelezen te hebben toch maar een HD Receiver besteld bij GPSShop in de hoop dat het zou werken. Niets is minder waar, wel verbinding met netwerk maar geen contact met server. Waar ik denk dat het probleem in zit is het feit dat de HDT receiver niet meet geactiveerd wordt door de server, omdat er geen nog niet gebruikte HDT receivers meer worden toegelaten op de server. Lekker beleidt van TOm TOm. Heb een vraag neergelegd bij TomTom, als hier niet snel een response op komt dan gaat de HDT retour afzender en de Go 730 op marktplaats. Dan ben ik er namelijk helemaal klaar mee.

John

Share this post


Link to post
Share on other sites
Na deze thread gelezen te hebben toch maar een HD Receiver besteld bij GPSShop in de hoop dat het zou werken. Niets is minder waar, wel verbinding met netwerk maar geen contact met server. Waar ik denk dat het probleem in zit is het feit dat de HDT receiver niet meet geactiveerd wordt door de server, omdat er geen nog niet gebruikte HDT receivers meer worden toegelaten op de server. Lekker beleidt van TOm TOm. Heb een vraag neergelegd bij TomTom, als hier niet snel een response op komt dan gaat de HDT retour afzender en de Go 730 op marktplaats. Dan ben ik er namelijk helemaal klaar mee.

John

En weer een gelukkige bezitter van een losse ontvanger.

De soap hier gaat ook nog steeds door. Na vanmorgen weer gebelt te hebben, gaat deze jongen het hele verhaal mondeling met de 2e lijn bespreken.

Het lijkt er idd op dat er geen nieuwe losse ontvangers meer worden toegelaten op de server zou je gaan denken.

Hier heb ik gewoon contact met het netwerk, maar in de server kom je niet.

Ik wordt teruggebelt vandaag nog. Ik ben benieuwd.

Gr Fred

Share this post


Link to post
Share on other sites
....

Ik wordt teruggebelt vandaag nog. Ik ben benieuwd.

....

En... al wat vernomen. Wij zijn ook benieuwd. :unknw:

Share this post


Link to post
Share on other sites
En... al wat vernomen. Wij zijn ook benieuwd. :unknw:

Volgens hun mail terug aan mij zou ik om 13 uur terug gebelt worden, maar je raad het al.

Algemene radiostilte. Tot nu nog niks gehoort, terwijl ik de hele middag thuis was.

Als ik iets hoor meld ik me meteen.

Ik heb die man ook vertelt dat ik dus niet de enige was met dit probleem. Nieuwe Losse ontvanger en geen verbinding met de server.

Gr Fred

Edited by kombi-force-rotax

Share this post


Link to post
Share on other sites

Vandaag eindelijk antwoord van TT 2e lijn, ik word geacht allerlei acties uit te voeren maar op geen enkel manier krijg ik t ehoren dat de fout bij TT ligt

Hieronder het antwoord van TT

Overzicht

Reactie (Bart T. H. (NL)) 17-09-2009 01:28 NM

Geachte heer ,

Hartelijk dank voor uw bericht aan TomTom Customer Support.

In deze e-mail vindt u een oplossing die u kunt toepassen wanneer de TomTom niet volledig opstart. Deze oplossing kan onder andere worden toegepast in de volgende situaties:

********** Applicatie verwijderen en opnieuw installeren ************

1. Reset uw TomTom (zie: http://www.tomtom.com/6971) en koppel deze aan uw computer.

2. Open [Deze Computer] vanaf uw bureaublad en zet vervolgens uw TomTom aan.

3. In het scherm verschijnt nu een nieuwe schijf, dit is uw TomTom. Dubbelklik op deze schijf.

4. Verwijder alle losse bestanden (Dit doet u als volgt: Aanklikken rechtermuisknop > Verwijderen).

• BELANGRIJK: De (gele) mappen met bijbehorende inhoud mogen NIET verwijderd worden.

5. Sluit het venster af wanneer de bestanden verwijderd zijn.

Download en installeer onze TomTom Home Software van de TomTom website

http://www.tomtom.com/services/service.php?id=16&tab=87

1. Sluit de TomTom aan de computer en start TomTom HOME op uw computer indien deze niet automatisch vanzelf opstart

2. Installeer hier de aangeboden applicatie (ook te vinden onder 'werk mijn GO/ONE bij')

Indien de applicatie niet wordt aangeboden:

1.Indien de TomTom is aangesloten, sluit u TomTom HOME af en ontkoppelt u uw apparaat

2.Ga vervolgens naar “Mijn Documenten” en ga naar de map [TomTom/HOME/Downloads]

3.Verwijder hier de inhoud van de map downloads (niet de map zelf)

4.Rechtsonder op het computerscherm vind U het logo van TomTom (de rode handen) als u het logo niet ziet, het omgekeerde v-the uitvouwen en 1 klik op de rechtermuisklik en afsluiten/exit selecteren!! belangrijk!!

Nu TomTom home terug starten en de updates installeren.

Dit doet door naar start> alle programmas> TT home 2 starten

Ontkoppel nu het apparaat en voer een reset uit http://www.tomtom.com/6971

******************** Clear Flash Uitvoeren ********************

Als u een van de onderstaande problemen heeft, kan het zijn dat er zich te veel bestanden bevinden in het flash-geheugen van het apparaat:

- U kunt de kaart op uw TomTom apparaat niet activeren, ook al heeft u een geldige productcode.

- U moet telkens wanneer u uw TomTom apparaat aansluit op uw mobiele telefoon uw wachtwoord invoeren.

- Uw instellingen zijn niet opgeslagen wanneer u uw TomTom apparaat uit- en weer aanzet.

Volg de instructies op de onderstaande webpagina:

http://www.tomtom.com/6179

******************** Fabrieksinstelleingen ********************

.

Wij vragen u uw fabrieks-instellingen te herstellen. Dit doet u op de volgende manier.

1: Schakel uw TomTom in

2: Kies in het hoofdmenu [Wijzig voorkeuren]

3. Zorg dat alle menu opties zichtbaar zijn [kies anders eerst voor de optie [Toon alle menu opties]

4: Ga vervolgens naar het laatste scherm en selecteer daar [Herstel fabrieks-instellingen]

4: Selecteer Ja (2 maal)

5: Volg daarna de stappen die in het scherm staan aangegeven.

6. Als de TomTom u een taal vraagt te selecteren, reset u uw TomTom weer ( Reset uw TomTom (zie: http://www.tomtom.com/6971) )

7. Na het resetten kunt u wel alle voorkeuren doorlopen.

******************** HD traffic ********************

- Verbind uw TomTom met de HD traffic ontvanger in de auto en zet uw TomTom aan.

- Reset de HDT Receiver met een paperclip

- Wacht voor de knipperende lampjes op uw HD reciever

- Koppel de reciever los, en koppel deze weer opnieuw aan.

Nu zal uw HD traffic service weer werken.

Indien u vragen of suggesties heeft horen wij dat graag.

Met vriendelijke groet,

TomTom Customer Care Team

-------------------------------------------------------------------------------------------------------------------------------------------------------

Het is niet mogelijk een reactie terug te zenden door direct te reageren op deze e-mail. U kunt een reactie terugzenden door deze vraag bij te werken op de website. In de onderstaande tekst staat stap-voor-stap beschreven hoe u dit kunt doen.

1. U gaat naar de website www.tomtom.com

2. Klik nu rechtsboven in het scherm op [Mijn TomTom login] en log in met uw gebruikersnaam en wachtwoord.

3. Klik op [Mijn TomTom] (het rode poppetje rechtsboven in het scherm)

4. Ga naar de middelste kolom en klik op [Mijn gestelde vragen]

5. Vervolgens klikt u op het stukje tekst onder onderwerp (van het incident 090904-005980)

6. Vervolgens klikt u onderaan dit bericht op de knop [Vraag Bijwerken]

7. Vul de informatie in bij Resultaten en/of extra informatie.

8. Als u een bestand wilt toevoegen, dan selecteert u via [bladeren] het bestand. Klik daarna op [bijlage toevoegen]

9. Om het bericht te versturen klikt u op de knop [bijgewerkte vraag indienen]

Ik vind het werkelijk van de zotte, mijn TT had verbinding( althans bij de netwerk tab was de status verbonden) alleen niet met de server dan ligt volgens mij het probleem bij TT en niet bij mij.

Bovenstaand antwoord is niet eens specifiek voor het HDT receiver maar een "oplossing " voor allerlei problemen die kunnen optreden en ze bieden nog niet eens de garantie dat het daarna wel zou werken.

Vooral de oplossing bij de HDT receiver is vreemd , bij eerder telefonisch contact met de helpdesk werd gezegd dat je bij het resetten van de HDT receiver deze niet aangesloten moest hebben op de TT hierboven dus weer wel. Lekker duidelijk en dat geeft de klant vertrouwen....

Ik blijf lekker met mijn TMC receiver rondrijden misschien niet realtime verkeersinfo ( soms zelfs elke paar seconden melding nieuwe verkeersinfo) maar dat bied HD traffic ook niet want zij updaten elke 3 minuten bij de hoogst toegestaande snelheid in NL ben je dan al 6 km verder en in die km's kan veel gebeuren!

Edited by Verso

Share this post


Link to post
Share on other sites

@ Verso.

Dit is precies de zelfde standaardmail die ik ook gekregen heb. Ik heb alles precies gedaan zoals er beschreven staat, maar werken vergeet het maar.

Ik zou vandaag hierover terug gebelt worden maar dat lukt ze dus ook niet.

Ik heb dus ook verbinding met het netwerk, maar niet met de server.

'Join the club zullen we maar zeggen.

Weet niet of je nog van plan bent te bellen morgen, maar meld maar dat er nog vele met het zelfde probleem zijn. :sad:

Bij mij stond er als laatste zinnetje nog onder. Indien het nu niet werkt moet uw TT voor reparatie opgestuurt worden. :lol: :unknw: :lol: :wink:

Ik geloof dat ze helemaal van god los zijn.

Gr Fred

Edited by kombi-force-rotax

Share this post


Link to post
Share on other sites

Interessant verhaal.

Mijn vrouw gebruikt een HDT ontvanger in haar auto waarvan het proefabonnement per 6 september verlopen is.

ik wilde bij halfords al een nieuwe ontvanger gaan kopen incl. kaartupdate omdat dat goedkoper is dan 6 maanden a 7,95 + een kaart, maar als dit allemaal niet meer blijkt te werken dan gaan we de HDT reciever die nu ingebouwd zit gewoon opnieuw activeren.

Scheelt me ook nog eens een hoop werk want die ontvanger zit achter het dashboard weggewerkt.

Share this post


Link to post
Share on other sites

kombi-force-rotax,

ik heb gelukkig mijn HDT receiver binnen de 8 dagen al naar Halfords teruggebracht maar dacht ik zal het TT antwoord niet onthouden aan de forum leden.

Ik vind het antwoord van TT van grote onkunde getuigen.

Het probleem ligt bij hun server daar krijgen de klanten geen contact mee, we hebben volgens onze netwerk tab wel verbinding met het netwerk.

Ik heb in mijn antwoord aan TT reeds melding gemaakt van de vele klachten op het jouwtomtom forum en ook mijn misgenoegen geuit van de omgekeerde prijspolitiek van LIVE en losse HDT receivers abonnementsverlenging.

Ik wens jullie succes met het probleem ik ben er gelukkig vanaf.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0